<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Netpbm - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/vendors/netpbm/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Mon, 02 Nov 2026 15:48:38 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/vendors/netpbm/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>Netpbm: Heap-based buffer overflow in sgitopnm (CVE-2026-120431)</title><link>https://feed.craftedsignal.io/briefs/2026-11-netpbm-heap-overflow/</link><pubDate>Mon, 02 Nov 2026 15:48:38 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-netpbm-heap-overflow/</guid><description>Netpbm is vulnerable to a heap-based buffer overflow in the sgitopnm utility via crafted SGI image files, potentially allowing for arbitrary code execution.</description><content:encoded><![CDATA[<p>Netpbm versions before 10.86.51, 11.x before 11.02.29, and 11.03 before 11.15.07 are affected by a heap-based buffer overflow vulnerability in the <code>sgitopnm</code> utility. The flaw exists within the <code>readChannels()</code> function and is triggered when processing RLE-compressed SGI images containing an oversized offset table. Successful exploitation can result in application crashes or arbitrary code execution.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation may lead to a crash of the <code>sgitopnm</code> utility (Denial of Service) or arbitrary code execution in the context of the user executing the tool.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Inventory all systems utilizing Netpbm or libraries relying on <code>sgitopnm</code>.</li>
<li>Update Netpbm to version 10.86.51, 11.02.29, 11.15.07, or later to address the vulnerability.</li>
<li>Implement file integrity monitoring for high-risk input processing pipelines that utilize legacy image processing libraries.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>vulnerability</category><category>remote-code-execution</category><category>buffer-overflow</category></item></channel></rss>