<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>GeoNode - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/vendors/geonode/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Fri, 06 Nov 2026 21:14:33 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/vendors/geonode/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>GeoNode: OS command injection via file upload (CVE-2026-33050)</title><link>https://feed.craftedsignal.io/briefs/2026-11-geonode-rce/</link><pubDate>Fri, 06 Nov 2026 21:14:33 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-geonode-rce/</guid><description>GeoNode versions prior to 5.1.0 are vulnerable to OS command injection via a malicious layer name in uploaded vector files, allowing authenticated attackers to achieve remote code execution.</description><content:encoded><![CDATA[<p>GeoNode is vulnerable to OS command injection (CVE-2026-33050) when processing vector files. An attacker with low-level privileges can provide a crafted layer name within an uploaded vector file that is not properly neutralized, leading to the execution of arbitrary OS commands on the host server. The vulnerability is confirmed in versions prior to 5.1.0.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows an authenticated attacker with file upload capabilities to execute arbitrary commands on the underlying server, resulting in a full compromise of confidentiality, integrity, and availability.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade GeoNode to version 5.1.0 or later immediately to apply the patch for CVE-2026-33050.</li>
<li>Audit logs for unauthorized or unexpected file uploads and shell-execution patterns if GeoNode is exposed.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category></item></channel></rss>