<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Blender - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/tags/blender/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Fri, 30 Oct 2026 17:37:37 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/tags/blender/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>Blender: Heap buffer overflow in thumbnail extractor (CVE-2026-119719)</title><link>https://feed.craftedsignal.io/briefs/2026-10-blender-overflow/</link><pubDate>Fri, 30 Oct 2026 17:37:37 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-10-blender-overflow/</guid><description>Blender versions prior to 4.5.15 and 5.x prior to 5.2.3 contain a heap buffer overflow in the thumbnail extractor that can lead to remote code execution when parsing maliciously crafted .blend files.</description><content:encoded><![CDATA[<p>Blender contains a heap-based buffer overflow vulnerability (CVE-2026-119719) located within the thumb_data_vertical_flip() function of the blend file thumbnail extractor. The vulnerability is triggered by a 32-bit integer overflow when processing a specially crafted .blend file.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows an attacker to achieve arbitrary code execution or cause an application crash. The vulnerability is triggered when the blender-thumbnailer or a Windows shell extension processes a .blend file containing malicious TEST block dimensions.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade Blender installations to version 4.5.15 or later, or 5.2.3 or later, to address the vulnerability.</li>
<li>In environments where patching is delayed, restrict the automatic previewing of .blend files by disabling thumbnail shell extensions or untrusted file processing utilities.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>vulnerability</category><category>remote-code-execution</category><category>blender</category></item><item><title>Blender: Heap buffer overflow vulnerability in point cache parsing (CVE-2026-119718)</title><link>https://feed.craftedsignal.io/briefs/2026-10-blender-cve-2026-119718/</link><pubDate>Fri, 30 Oct 2026 17:37:29 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-10-blender-cve-2026-119718/</guid><description>Blender contains a heap-based buffer overflow in the ptcache_data_alloc function, allowing attackers to trigger memory corruption and potential code execution via a maliciously crafted point cache file.</description><content:encoded><![CDATA[<p>Blender versions prior to 4.5.15 and 5.x versions prior to 5.2.3 are affected by a heap buffer overflow vulnerability identified as CVE-2026-119718. The vulnerability originates from an integer overflow within the ptcache_data_alloc() function during the processing of point cache files.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation of this vulnerability allows an attacker to achieve arbitrary code execution within the context of the user running the Blender application. If code execution is not achieved, the malformed input can cause an application crash, leading to a denial of service for the end user.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade Blender instances to version 4.5.15 or 5.2.3 and later to mitigate the vulnerability.</li>
<li>Advise users to avoid opening .blend files or associated point cache files from untrusted or unverified sources.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>vulnerability</category><category>remote-code-execution</category><category>blender</category></item></channel></rss>