<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>TinyMCE (&gt;= 8.5.1, &lt; 8.9.3) - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/products/tinymce--8.5.1--8.9.3/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Tue, 27 Oct 2026 23:58:28 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/products/tinymce--8.5.1--8.9.3/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>TinyMCE: Stored cross-site scripting in media plugin (CVE-2026-116675)</title><link>https://feed.craftedsignal.io/briefs/2026-10-tinymce-xss/</link><pubDate>Tue, 27 Oct 2026 23:58:28 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-10-tinymce-xss/</guid><description>TinyMCE is vulnerable to stored Cross-Site Scripting (XSS) via the media plugin, allowing attackers to inject malicious scripts through the data-mce-object attribute before sanitization occurs.</description><content:encoded><![CDATA[<p>TinyMCE versions 8.5.1 up to 8.9.2 and 7.9.3 are vulnerable to a stored XSS vulnerability within the media plugin. An attacker can craft inputs using the 'data-mce-object' attribute that the editor fails to sanitize before execution, leading to potential script execution in the context of the user's session.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation results in stored Cross-Site Scripting. This allows attackers to execute arbitrary JavaScript in the browser of any user who views the affected content within the TinyMCE editor.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade TinyMCE to version 8.9.3 or higher.</li>
<li>Upgrade TinyMCE to version 7.9.4 or higher.</li>
<li>Audit existing content stored via the media plugin if the application is highly targeted.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>xss</category><category>web-vulnerability</category></item></channel></rss>