<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>James (&lt; 3.9.1) - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/products/james--3.9.1/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Fri, 06 Nov 2026 17:22:54 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/products/james--3.9.1/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>Apache James: ManageSieve cross-user path traversal (CVE-2026-76168)</title><link>https://feed.craftedsignal.io/briefs/2026-11-apache-james-path-traversal/</link><pubDate>Fri, 06 Nov 2026 17:22:54 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-apache-james-path-traversal/</guid><description>Apache James versions prior to 3.9.1 are vulnerable to a path traversal flaw in the SieveFileRepository, allowing authenticated attackers to inject malicious SIEVE scripts into other users accounts.</description><content:encoded><![CDATA[<p>Apache James Server versions prior to 3.9.1 contain an improper input validation vulnerability in the SieveFileRepository component (CVE-2026-76168). An attacker with authenticated access to the ManageSieve service can use path traversal techniques to bypass security boundaries, allowing them to write or overwrite SIEVE scripts associated with other users.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows a malicious actor to perform unauthorized actions on behalf of other users, including the interception of email traffic or the implementation of denial-of-service conditions by corrupting user-defined SIEVE rules.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade Apache James Server to version 3.9.1 or later immediately.</li>
<li>Monitor ManageSieve protocol logs for unusual script management activity.</li>
<li>Audit existing SIEVE scripts for unexpected file path references or suspicious redirect/discard rules that may indicate prior exploitation.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category></item></channel></rss>