<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Imgproxy (&lt; 4.0.16) - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/products/imgproxy--4.0.16/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Sun, 08 Nov 2026 02:55:39 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/products/imgproxy--4.0.16/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>imgproxy: Heap buffer overflow in ICO loader (CVE-2026-123614)</title><link>https://feed.craftedsignal.io/briefs/2026-11-08-imgproxy-cve-2026-123614/</link><pubDate>Sun, 08 Nov 2026 02:55:39 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-08-imgproxy-cve-2026-123614/</guid><description>imgproxy versions 4.0.0 through 4.0.15 contain an integer overflow in the ICO image loader, enabling remote attackers to trigger heap memory corruption leading to potential code execution.</description><content:encoded><![CDATA[<p>imgproxy versions 4.0.0 to 4.0.15 are affected by an integer overflow vulnerability in the ICO image loader component. An attacker can craft an ICO image with a specifically manipulated data_size parameter. When processed by the application, this value triggers an integer overflow in the memory allocation logic within the vips/icoload.c source file. This results in a heap buffer overflow, which can be leveraged to crash the service (Denial of Service) or execute arbitrary code.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows remote, unauthenticated attackers to cause a process crash or potentially achieve remote code execution on the server running imgproxy.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade imgproxy to version 4.0.16 or later immediately.</li>
<li>Audit logs for repeated crashes or unusual memory spikes associated with the imgproxy service, which may indicate exploitation attempts.</li>
</ul>
]]></content:encoded><category domain="severity">critical</category><category domain="type">advisory</category><category>cve-2026-123614</category><category>integer-overflow</category><category>memory-corruption</category><category>remote-code-execution</category></item></channel></rss>