<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>AgentScope (&lt;= 2.0.8) - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/products/agentscope--2.0.8/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Thu, 05 Nov 2026 16:20:55 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/products/agentscope--2.0.8/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>AgentScope: Incorrect authorization in Bash Tool (CVE-2026-123023)</title><link>https://feed.craftedsignal.io/briefs/2026-11-agentscope-auth-bypass-4f8d4050/</link><pubDate>Thu, 05 Nov 2026 16:20:55 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-agentscope-auth-bypass-4f8d4050/</guid><description>AgentScope versions 2.0.8 and earlier contain an authorization flaw in the Bash Tool component that allows remote attackers to bypass permission checks and execute unauthorized commands.</description><content:encoded><![CDATA[<p>A vulnerability exists in the <code>check_permissions</code> function within <code>src/agentscope/tool/_builtin/_bash.py</code> of the AgentScope Bash Tool. The vulnerability is caused by incorrect authorization logic, which can be exploited remotely to perform unauthorized actions. A public exploit is available. This issue is resolved in version 2.0.9.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows a remote attacker to bypass intended authorization constraints, resulting in unauthorized command execution via the affected Bash tool component.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade AgentScope to version 2.0.9 or later immediately.</li>
<li>Audit logs for instances of the AgentScope Bash Tool execution to identify unauthorized access attempts.</li>
<li>If upgrading is not immediately possible, restrict network access to environments hosting AgentScope instances.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category></item></channel></rss>