{"description":"Trending threats, MITRE ATT\u0026CK coverage, and detection metadata. Fed continuously.","favicon":"https://feed.craftedsignal.io/favicon-32x32.png","feed_url":"https://feed.craftedsignal.io/products/agentscope--2.0.8/feed.json","home_page_url":"https://feed.craftedsignal.io/","icon":"https://feed.craftedsignal.io/apple-touch-icon.png","items":[{"_cs_actors":[],"_cs_cpes":["cpe:2.3:a:agentscope-ai:agentscope:*:*:*:*:*:*:*:*"],"_cs_cves":[{"cvss":7.3,"id":"CVE-2026-123023"}],"_cs_exploited":false,"_cs_has_poc":false,"_cs_poc_references":[],"_cs_products":["AgentScope (\u003c= 2.0.8)"],"_cs_severities":["high"],"_cs_tags":[],"_cs_type":"advisory","_cs_vendors":["agentscope-ai"],"content_html":"\u003cp\u003eA vulnerability exists in the \u003ccode\u003echeck_permissions\u003c/code\u003e function within \u003ccode\u003esrc/agentscope/tool/_builtin/_bash.py\u003c/code\u003e of the AgentScope Bash Tool. The vulnerability is caused by incorrect authorization logic, which can be exploited remotely to perform unauthorized actions. A public exploit is available. This issue is resolved in version 2.0.9.\u003c/p\u003e\n\u003ch2 id=\"impact\"\u003eImpact\u003c/h2\u003e\n\u003cp\u003eSuccessful exploitation allows a remote attacker to bypass intended authorization constraints, resulting in unauthorized command execution via the affected Bash tool component.\u003c/p\u003e\n\u003ch2 id=\"recommendation\"\u003eRecommendation\u003c/h2\u003e\n\u003cul\u003e\n\u003cli\u003eUpgrade AgentScope to version 2.0.9 or later immediately.\u003c/li\u003e\n\u003cli\u003eAudit logs for instances of the AgentScope Bash Tool execution to identify unauthorized access attempts.\u003c/li\u003e\n\u003cli\u003eIf upgrading is not immediately possible, restrict network access to environments hosting AgentScope instances.\u003c/li\u003e\n\u003c/ul\u003e\n","date_modified":"2026-11-05T16:20:55Z","date_published":"2026-11-05T16:20:55Z","id":"https://feed.craftedsignal.io/briefs/2026-11-agentscope-auth-bypass-4f8d4050/","summary":"AgentScope versions 2.0.8 and earlier contain an authorization flaw in the Bash Tool component that allows remote attackers to bypass permission checks and execute unauthorized commands.","title":"AgentScope: Incorrect authorization in Bash Tool (CVE-2026-123023)","url":"https://feed.craftedsignal.io/briefs/2026-11-agentscope-auth-bypass-4f8d4050/"}],"language":"en","title":"CraftedSignal Threat Feed - AgentScope (\u003c= 2.0.8)","version":"https://jsonfeed.org/version/1.1"}