<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Affiliate-Toolkit – Multi-Network Affiliate &amp; Amazon Product Display (&lt;= 3.9.2) - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/products/affiliate-toolkit--multi-network-affiliate--amazon-product-display--3.9.2/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Wed, 28 Oct 2026 06:26:21 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/products/affiliate-toolkit--multi-network-affiliate--amazon-product-display--3.9.2/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>affiliate-toolkit: Stored Cross-Site Scripting via atkp_product_producturl (CVE-2026-111314)</title><link>https://feed.craftedsignal.io/briefs/2026-10-affiliate-toolkit-xss/</link><pubDate>Wed, 28 Oct 2026 06:26:21 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-10-affiliate-toolkit-xss/</guid><description>The affiliate-toolkit WordPress plugin contains a stored XSS vulnerability in the atkp_product_producturl parameter, allowing unauthenticated or contributor-level attackers to inject arbitrary web scripts.</description><content:encoded><![CDATA[<p>The affiliate-toolkit - Multi-Network Affiliate &amp; Amazon Product Display plugin for WordPress (versions 3.9.2 and earlier) is vulnerable to Stored Cross-Site Scripting (XSS). The vulnerability exists in the atkp_product_producturl parameter due to insufficient input sanitization and output escaping.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows for the execution of arbitrary web scripts in the context of a user's browser session. When the plugin AJAX handler is enabled, unauthenticated attackers can trigger this vulnerability by providing a target product ID. In default configurations, the attack requires contributor-level privileges or higher.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Update the affiliate-toolkit WordPress plugin to the version patched beyond 3.9.2.</li>
<li>Audit existing product URLs stored within the affiliate-toolkit plugin configuration for malicious script injections.</li>
<li>Monitor WordPress administrative logs for unusual product creation or modification activity originating from contributor-level accounts.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>xss</category><category>wordpress</category><category>plugin</category></item></channel></rss>