<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Cpe:2.3:a:node-Opcua:node-Opcua:*:*:*:*:*:*:*:* - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/cpes/cpe2.3anode-opcuanode-opcua/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Wed, 04 Nov 2026 00:47:18 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/cpes/cpe2.3anode-opcuanode-opcua/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>node-opcua: Namespace-level RBAC bypass (CVE-2026-95860)</title><link>https://feed.craftedsignal.io/briefs/2026-11-node-opcua-rbac-bypass/</link><pubDate>Wed, 04 Nov 2026 00:47:18 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-node-opcua-rbac-bypass/</guid><description>A namespace-level RBAC fail-open vulnerability in node-opcua (CVE-2026-95860) allows unauthenticated network clients to perform unauthorized writes or method calls due to improper role permission inheritance.</description><content:encoded><![CDATA[<p>node-opcua is affected by an authorization bypass vulnerability (CVE-2026-95860) occurring in versions 2.42.0 through 2.179.0. The vulnerability stems from a flaw in <code>SessionContext.getApplicableRolePermissions</code>, which fails to correctly read <code>DefaultRolePermissions</code> metadata when per-node <code>RolePermissions</code> are not explicitly defined. Instead of inheriting restrictive defaults, the runtime treats the missing configuration as permissive. This allows anonymous network clients to write to variables or call bound methods that were intended to be protected by namespace-level access controls.</p>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows unauthenticated remote attackers to bypass namespace-level authorization, granting them the ability to modify variables or execute functions on the OPC UA server that should otherwise be restricted. Servers with no declared default policies, or those using explicit per-node permissions, are not impacted.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade node-opcua to version 2.180.0 or later to patch the underlying logic error.</li>
<li>Review OPC UA server configurations to ensure that per-node permissions are explicitly defined rather than relying solely on namespace-level default inheritance until the upgrade is completed.</li>
<li>Identify all instances of the <code>node-opcua</code> package within the environment and verify the version against the vulnerable range (2.42.0 &lt;= version &lt; 2.180.0).</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>vulnerability</category><category>rbac</category><category>opc-ua</category><category>node-opcua</category><category>authorization-bypass</category></item></channel></rss>