<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Cpe:2.3:a:glpi-Project:glpi:*:*:*:*:*:*:*:* - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/cpes/cpe2.3aglpi-projectglpi/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Thu, 29 Oct 2026 14:37:42 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/cpes/cpe2.3aglpi-projectglpi/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>GLPI: Remote Code Execution via Local File Inclusion (CVE-2025-24801)</title><link>https://feed.craftedsignal.io/briefs/2026-10-glpi-rce/</link><pubDate>Thu, 29 Oct 2026 14:37:42 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-10-glpi-rce/</guid><description>GLPI versions before 10.0.18 are vulnerable to remote code execution through Local File Inclusion, where authenticated users can modify file extension allowlists to execute arbitrary PHP payloads.</description><content:encoded><![CDATA[<p>GLPI versions prior to 10.0.18 contain a vulnerability (CVE-2025-24801) allowing Remote Code Execution (RCE) via Local File Inclusion. An authenticated user can interact with the <code>front/documenttype.form.php</code> endpoint and manipulate the <code>ext</code> parameter to permit the upload of unauthorized file types, such as PHP scripts. Successful exploitation results in arbitrary command execution on the host server.</p>
<h2 id="attack-chain">Attack Chain</h2>
<ol>
<li>Attacker authenticates to the GLPI application with low-level privileges.</li>
<li>Attacker navigates to the <code>front/documenttype.form.php</code> endpoint.</li>
<li>Attacker modifies the allowed file extensions configuration for Document Types via the <code>ext</code> parameter in the request body.</li>
<li>Attacker uploads a malicious PHP file through the application's file upload interface.</li>
<li>The application saves the file to a location accessible by the web server.</li>
<li>Attacker triggers execution of the uploaded file by navigating to its path, resulting in RCE.</li>
</ol>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows an authenticated attacker to execute arbitrary commands with the privileges of the web server, leading to full compromise of the GLPI application instance.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Upgrade GLPI to version 10.0.18 or later immediately to patch CVE-2025-24801.</li>
<li>Audit GLPI user accounts to identify and restrict low-privileged users with access to configuration-altering endpoints.</li>
<li>Monitor web server logs for suspicious POST requests to <code>front/documenttype.form.php</code> and subsequent direct access to uploaded files in the web-accessible directories.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category></item></channel></rss>