<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Cpe:2.3:a:buddyforms:buddyforms:*:*:*:*:*:wordpress:*:* - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/cpes/cpe2.3abuddyformsbuddyformswordpress/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Fri, 06 Nov 2026 13:09:31 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/cpes/cpe2.3abuddyformsbuddyformswordpress/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>BuddyForms: Privilege escalation via form submission (CVE-2026-107622)</title><link>https://feed.craftedsignal.io/briefs/2026-11-buddyforms-privilege-escalation/</link><pubDate>Fri, 06 Nov 2026 13:09:31 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-buddyforms-privilege-escalation/</guid><description>The BuddyForms WordPress plugin is vulnerable to unauthenticated privilege escalation via a form-type confusion flaw that allows attackers to create administrator accounts.</description><content:encoded><![CDATA[<p>The BuddyForms plugin for WordPress (versions 2.10.5 and earlier) contains a critical privilege escalation vulnerability due to improper input validation and missing authorization checks. The plugin's public submission handler, <code>buddyforms_form_response_no_ajax()</code>, improperly trusts the <code>bf_post_type</code> parameter when handling new object creation. An unauthenticated attacker can supply a malicious form configuration via the <code>buddyforms_options</code> parameter to override the <code>new_user_role</code> setting. This allows an attacker to register a new account on a site where &quot;Anyone can register&quot; is enabled, granting that account administrator-level privileges.</p>
<h2 id="attack-chain">Attack Chain</h2>
<ol>
<li>Attacker identifies a WordPress site with the BuddyForms plugin and &quot;Anyone can register&quot; enabled.</li>
<li>Attacker crafts a POST request to the <code>buddyforms_form_response_no_ajax</code> handler.</li>
<li>Attacker specifies a malicious <code>bf_post_type</code> and injects an arbitrary form configuration via the <code>buddyforms_options</code> parameter.</li>
<li>The plugin fails to validate the request or verify authorization, permitting the creation of a rogue form entry in the global registry.</li>
<li>The rogue form is configured to assign the administrator role to new registrants via the <code>new_user_role</code> field.</li>
<li>Attacker submits a user registration through the newly created rogue form.</li>
<li>WordPress creates the account with administrative privileges, resulting in full site compromise.</li>
</ol>
<h2 id="impact">Impact</h2>
<p>Successful exploitation allows an unauthenticated attacker to gain full administrative control over the WordPress site.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Immediately update the BuddyForms plugin to the latest patched version (post-2.10.5).</li>
<li>If an update cannot be applied immediately, disable public registration on the WordPress site.</li>
<li>Audit existing BuddyForms forms for unauthorized configuration changes or unexpected <code>new_user_role</code> values.</li>
<li>Audit the WordPress user database for newly created administrator accounts.</li>
</ul>
]]></content:encoded><category domain="severity">critical</category><category domain="type">advisory</category><category>wordpress</category><category>plugin</category><category>vulnerability</category><category>privilege-escalation</category></item></channel></rss>