<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:webfeeds="http://webfeeds.org/rss/1.0"><channel><title>Cpe:2.3:a:advanced_members_for_acf_project:advanced_members_for_acf:*:*:*:*:*:wordpress:*:* - CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/cpes/cpe2.3aadvanced_members_for_acf_projectadvanced_members_for_acfwordpress/</link><description>Trending threats, MITRE ATT&amp;CK coverage, and detection metadata. Fed continuously.</description><generator>Hugo</generator><language>en</language><managingEditor>hello@craftedsignal.io</managingEditor><webMaster>hello@craftedsignal.io</webMaster><lastBuildDate>Fri, 06 Nov 2026 13:11:59 +0000</lastBuildDate><atom:link href="https://feed.craftedsignal.io/cpes/cpe2.3aadvanced_members_for_acf_projectadvanced_members_for_acfwordpress/feed.xml" rel="self" type="application/rss+xml"/><image><url>https://feed.craftedsignal.io/favicon-32x32.png</url><title>CraftedSignal Threat Feed</title><link>https://feed.craftedsignal.io/</link><width>32</width><height>32</height></image><webfeeds:icon>https://feed.craftedsignal.io/favicon.svg</webfeeds:icon><item><title>Advanced Members for ACF: Privilege Escalation via Password Overwrite (CVE-2026-116624)</title><link>https://feed.craftedsignal.io/briefs/2026-11-acf-privilege-escalation/</link><pubDate>Fri, 06 Nov 2026 13:11:59 +0000</pubDate><author>hello@craftedsignal.io</author><guid isPermaLink="true">https://feed.craftedsignal.io/briefs/2026-11-acf-privilege-escalation/</guid><description>An authenticated attacker can escalate privileges to administrator by exploiting a logical error in the Advanced Members for ACF WordPress plugin to overwrite the administrator password.</description><content:encoded><![CDATA[<p>The Advanced Members for ACF WordPress plugin (versions 1.3.0 and below) is vulnerable to privilege escalation via the [advanced-members-account-password] shortcode. An operator-precedence bug in the pre_update_value function within acf/fields/class-user-password.php causes the system to incorrectly authorize password updates by defaulting the $user_id to boolean true, which evaluates to ID 1 via PHP loose equality. Additionally, a flaw in the amem_save_all_fields function fails to respect field exclusion guards, allowing the password update to proceed even if the application expects it to be blocked.</p>
<h2 id="attack-chain">Attack Chain</h2>
<ol>
<li>Attacker authenticates to a WordPress site as a user with at least Subscriber-level access.</li>
<li>Attacker navigates to a page containing the [advanced-members-account-password] shortcode.</li>
<li>Attacker submits the form containing the acf[_amem_local_user_password] parameter.</li>
<li>The plugin's pre_update_value function processes the request and hits the PHP operator-precedence bug.</li>
<li>The authorization logic incorrectly evaluates $user_id as boolean true, bypassing the _can_edit() check.</li>
<li>The system executes wp_update_user(), targeting user ID 1 due to type casting of the boolean ID.</li>
<li>The amem_save_all_fields function overrides the exclusion guard, ensuring the malicious password change is processed.</li>
<li>The administrator account password is overwritten with the attacker-provided value, granting full administrative access.</li>
</ol>
<h2 id="impact">Impact</h2>
<p>Authenticated users with low-level privileges can gain full administrative access to the WordPress site, leading to potential data exfiltration, site defacement, or total system compromise.</p>
<h2 id="recommendation">Recommendation</h2>
<ul>
<li>Identify all WordPress sites utilizing the Advanced Members for ACF plugin.</li>
<li>Update to a version beyond 1.3.0 immediately when a patch becomes available.</li>
<li>Disable the [advanced-members-account-password] shortcode or restrict access to administrative-only pages until a patch is applied.</li>
<li>Audit user management logs for unexpected password change events for administrator accounts.</li>
</ul>
]]></content:encoded><category domain="severity">high</category><category domain="type">advisory</category><category>wordpress</category><category>privilege-escalation</category><category>web-vulnerability</category></item></channel></rss>