PGALL for WooCommerce: Unauthenticated settings change (CVE-2026-95597)
An unauthenticated settings change vulnerability in the PGALL for WooCommerce plugin allows attackers to manipulate payment gateway configurations via AJAX by harvesting nonces from public checkout pages.
CVE search metadata
CVE search record: CVE-2026-95597. Severity: medium. CVSS: 6.5. EPSS: 0.24%. KEV: no. Product: PGALL for WooCommerce (<= 5.5.17). Brief: PGALL for WooCommerce: Unauthenticated settings change (CVE-2026-95597). Brief link: https://feed.craftedsignal.io/briefs/2026-11-pgall-woocommerce-settings/
Triage facts
Revision 1- Applicability
- PGALL for WooCommerce (<= 5.5.17)
- Evidence
- Unknown
- Severity
- Medium
- Action
- Immediate escalation
- Sources
- 4 public sources
- Freshness
- Revision 1Nov 7, 15:58 UTC
- Detection
- 1 rule
- Vulnerabilities
- 1 CVE
- Source quality
- A1Very likely
The PGALL for WooCommerce WordPress plugin contains a vulnerability (CVE-2026-95597) that enables unauthenticated users to change plugin settings. The vulnerability exists within the AJAX handler pgall-for-woocommerce-pafw_ajax_action, which is exposed to logged-out users. The handler lacks proper capability checks or allow-listing for the methods it executes. Attackers can obtain the required nonce from the public WooCommerce checkout page and subsequently invoke methods such as save_account_details or process_admin_options to modify payment gateway configurations, including bank account details.
Attack Chain
- Attacker visits the public shop page to discover a product.
- Attacker adds the product to the cart to establish an anonymous WooCommerce session.
- Attacker navigates to the public checkout page to harvest the
_pafw._wpnonce. - Attacker crafts a POST request to
/wp-admin/admin-ajax.php. - Attacker provides the harvested nonce along with parameters
payment_method=bacsandpayment_action=save_account_details. - The plugin handler executes the payment gateway method without authorization.
- The merchant's bank account details are overwritten with attacker-controlled data.
Impact
Successful exploitation allows unauthenticated attackers to modify critical store payment settings. This can lead to financial fraud by redirecting customer payments to attacker-controlled bank accounts and disrupting site availability by disabling payment gateways.
Recommendation
- Update the PGALL for WooCommerce plugin to version 5.5.18 or later immediately.
- Review current payment gateway configurations for unauthorized changes to bank details or gateway status.
- Implement Web Application Firewall (WAF) rules to inspect and filter POST requests to
admin-ajax.phpcontainingpgall-for-woocommerce-pafw_ajax_actionfrom unauthenticated or suspicious IP addresses.
Immediate actions
Update PGALL for WooCommerce to 5.5.18 or later
Threat Hunt
Review web server logs for high frequency of POST requests to admin-ajax.php with action=pgall-for-woocommerce-pafw_ajax_action
Data: Web server access logs
Mitigations
Apply WAF rule to block unauthorized admin-ajax.php requests
CVE-2026-95597
Detection coverage 1
Detect CVE-2026-95597 Exploitation - Unauthenticated AJAX Action
highDetects exploitation attempts against PGALL for WooCommerce by monitoring POST requests to admin-ajax.php involving the vulnerable AJAX action.
Detection queries are available on the platform. Get full rules →