Skip to content
Threat Feed
high advisory

FluentCart: Arbitrary file deletion (CVE-2026-120577)

The FluentCart WordPress plugin contains an arbitrary file deletion vulnerability in the deleteFile function that allows authenticated attackers to delete sensitive server files, potentially leading to remote code execution.

CVE search metadata

CVE search record: CVE-2026-120577. Severity: high. CVSS: 8.1. KEV: no. Product: FluentCart (<= 1.6.2). Brief: FluentCart: Arbitrary file deletion (CVE-2026-120577). Brief link: https://feed.craftedsignal.io/briefs/2026-11-fluentcart-file-deletion/

Triage facts

Revision 1
Applicability
FluentCart (<= 1.6.2)
Evidence
Unknown
Severity
High
Action
Elevated
Sources
1 public source
Freshness
Revision 1Nov 3, 05:55 UTC
Vulnerabilities
1 CVE
Source quality
A2Roughly even chance

The FluentCart plugin for WordPress (versions 1.6.2 and earlier) is susceptible to an arbitrary file deletion vulnerability. This flaw stems from improper file path validation within the plugin's deleteFile function. Authenticated users with custom-level access or higher can leverage this vulnerability to delete critical files on the web server, such as wp-config.php, which can result in application compromise or remote code execution.

Impact

Successful exploitation allows for the deletion of arbitrary files on the hosting server. Deleting critical application configuration files, such as wp-config.php, may force the application into an installation state or facilitate further exploitation leading to remote code execution.

Recommendation

  • Update the FluentCart plugin to the latest available version (beyond 1.6.2) to remediate the path validation flaw.
  • Review WordPress user role assignments to ensure that users with custom-level access and above are limited to trusted individuals.
  • Audit web server file access logs for requests targeting the deleteFile function logic, typically associated with administrative or plugin-specific API endpoints.

Immediate actions

Upgrade FluentCart to a version exceeding 1.6.2

IT Operations 48h

Threat Hunt

Identify authenticated users with custom-level roles performing administrative file operations.

T1059.003 medium medium confidence hunt now

Data: Web server access logs, WordPress plugin activity logs

Mitigations

Update FluentCart plugin to the version containing the patch for CVE-2026-120577.

immediate IT Operations

CVE-2026-120577