Simply Schedule Appointments: Broken access control (CVE-2026-94074)
A public exploit exists for CVE-2026-94074 in the Simply Schedule Appointments WordPress plugin, allowing unauthenticated attackers to bypass REST API authorization and delete or retrieve sensitive customer appointment data.
CVE search metadata
CVE search record: CVE-2026-94074. Severity: medium. CVSS: 6.5. EPSS: 0.20%. KEV: no. Product: simply-schedule-appointments (<= 1.6.12.29). Brief: Simply Schedule Appointments: Broken access control (CVE-2026-94074). Brief link: https://feed.craftedsignal.io/briefs/2026-11-cve-2026-94074-ssa/
Triage facts
Revision 1- Applicability
- simply-schedule-appointments (<= 1.6.12.29)
- Evidence
- Unknown
- Severity
- High
- Action
- Elevated
- Sources
- 4 public sources
- Freshness
- Revision 1Nov 7, 14:08 UTC
- Detection
- 1 rule
- Vulnerabilities
- 1 CVE
- Source quality
- B2Very likely
CVE-2026-94074 is a broken access control vulnerability in the Simply Schedule Appointments WordPress plugin (versions 1.6.12.29 and earlier). The REST API endpoint /ssa/v1/appointments relies on an MD5 HMAC token for authentication. Due to an input validation error, supplying an appointment ID as a float (e.g., '1.9') causes the application to generate a predictable HMAC token. This allows unauthenticated attackers to access, cancel, or delete appointments. The vulnerability was reported by Mor Golan and a proof-of-concept exploit script is publicly available.
Attack Chain
- Attacker identifies a site running a vulnerable version of the Simply Schedule Appointments plugin.
- Attacker crafts a request to the
/ssa/v1/appointmentsendpoint using an appointment ID formatted as a float (e.g.,1.9). - The plugin application incorrectly handles the float ID, bypassing the intended token validation logic.
- Attacker computes the HMAC token offline using the public salt and the manipulated float ID.
- Attacker sends the request with the forged token to the REST API.
- The API returns sensitive customer information, including name, email, phone number, and a valid
public_token. - Attacker uses the harvested
public_tokento authenticate subsequent requests to cancel or delete the appointment.
Impact
Successful exploitation allows unauthenticated users to perform unauthorized actions, including the exfiltration of personally identifiable information (PII) and the unauthorized deletion of appointment records.
Recommendation
- Update the Simply Schedule Appointments plugin to version 1.6.12.31 or later immediately.
- Audit access logs for anomalous requests to the
/ssa/v1/appointmentsendpoint, specifically those containing float values or unexpected parameters in the appointment ID query. - Review WordPress plugin inventory to ensure no sites are running the identified vulnerable versions.
Immediate actions
Patch Simply Schedule Appointments to 1.6.12.31.
Deploy the Sigma rule to monitor for exploitation attempts.
Threat Hunt
Identify previous successful unauthorized access attempts.
Data: Web server access logs
Mitigations
Upgrade plugin to 1.6.12.31.
CVE-2026-94074
Detection coverage 1
Detect Exploitation of CVE-2026-94074
highDetects exploitation attempts against the Simply Schedule Appointments REST API by searching for float-formatted appointment IDs in the URI query.
Detection queries are available on the platform. Get full rules →