Apache HTTP Server: TLS 1.3 Session Resumption Authentication Bypass (CVE-2025-23048)
CVE-2025-23048 allows an attacker to bypass client certificate authentication in Apache HTTP Server versions 2.4.35 through 2.4.62 by resuming a TLS 1.3 session across virtual hosts with different CA configurations.
CVE search metadata
CVE search record: CVE-2025-23048. Severity: critical. CVSS: 9.1. EPSS: 1.04%. KEV: no. Product: Apache HTTP Server (2.4.35-2.4.62). Brief: Apache HTTP Server: TLS 1.3 Session Resumption Authentication Bypass (CVE-2025-23048). Brief link: https://feed.craftedsignal.io/briefs/2026-11-cve-2025-23048/
Triage facts
Revision 1- Applicability
- Apache HTTP Server (2.4.35-2.4.62)
- Evidence
- Unknown
- Severity
- High
- Action
- Elevated
- Sources
- 2 public sources
- Freshness
- Revision 1Nov 1, 09:58 UTC
- Vulnerabilities
- 1 CVE
- Source quality
- B2Likely
Apache HTTP Server versions 2.4.35 through 2.4.62 are vulnerable to a client certificate authentication bypass (CVE-2025-23048) when TLS 1.3 session resumption is enabled. The vulnerability occurs because the server may incorrectly reuse a session established on one virtual host (vhost1) for a different virtual host (vhost2) that requires a distinct client CA certificate. This allows an attacker possessing a valid certificate for vhost1 to access protected resources on vhost2 without providing a certificate trusted by vhost2.
Attack Chain
- Attacker identifies two virtual hosts on a target Apache server configured with differing
SSLCACertificateFiledirectives. - Attacker performs a full TLS 1.3 handshake with the first virtual host using a valid client certificate trusted by that specific host.
- The Apache server accepts the handshake and issues a session ticket.
- Attacker captures the session ticket or maintains the session state.
- Attacker initiates a connection to the second virtual host (vhost2) requesting a restricted path.
- Attacker uses the session ticket from vhost1 to resume the TLS session on vhost2.
- Apache incorrectly validates the resumed session, bypassing the client certificate check required for vhost2.
- Attacker gains unauthorized access to protected resources on vhost2.
Recommendation
- Upgrade Apache HTTP Server to version 2.4.64 or later to address the vulnerability.
- If upgrading is not immediately possible, set
SSLStrictSNIVHostCheck onwithin the virtual host configuration for all TLS 1.3 enabled hosts that rely on distinct client certificate authorities. This setting prevents cross-SNI session resumption and mitigates the bypass.
Immediate actions
Patch Apache HTTP Server to 2.4.64 or later.
Deploy SSLStrictSNIVHostCheck on for virtual hosts requiring distinct client CAs.
Threat Hunt
Audit Apache configuration files for TLS 1.3 virtual hosts that have inconsistent SSLCACertificateFile settings.
Data: Apache configuration file exports (httpd.conf, httpd-vhosts.conf)
Mitigations
Upgrade Apache HTTP Server to 2.4.64+
CVE-2025-23048