medium
advisory
Google Brotli Compression Library Vulnerabilities
Google has released security updates for the Brotli compression library to address vulnerabilities affecting multiple version branches.
Triage facts
Revision 1- Applicability
- Brotli (1.0.3 <= v < 1.0.10), Brotli (1.1.0 <= v < 1.1.1) +1
- Evidence
- Unknown
- Severity
- Medium
- Action
- Elevated
- Sources
- 2 public sources
- Freshness
- Revision 1Oct 27, 03:53 UTC
- Source quality
- A1Roughly even chance
Google has released security updates for the Brotli compression library. The affected versions include 1.0.3 through 1.0.9, 1.1.0, and 1.2.0. Users and administrators are advised to update to versions 1.0.10, 1.1.1, or 1.2.1 respectively to mitigate security risks. The source advisory provides patch information but does not detail specific vulnerability classes or exploitation methods.
Recommendation
- Identify applications or services in the environment that utilize the Brotli compression library as a dependency.
- Update Brotli libraries to versions 1.0.10, 1.1.1, or 1.2.1 depending on the current branch in use.
- Monitor the official Brotli GitHub repository for further security-related disclosures or patches.
Mitigations
Upgrade Brotli library dependencies to versions 1.0.10, 1.1.1, or 1.2.1
immediate
IT Operations
Brotli vulnerabilities