GLPI: Remote Code Execution via Local File Inclusion (CVE-2025-24801)
GLPI versions before 10.0.18 are vulnerable to remote code execution through Local File Inclusion, where authenticated users can modify file extension allowlists to execute arbitrary PHP payloads.
CVE search metadata
CVE search record: CVE-2025-24801. Severity: high. CVSS: 8.5. EPSS: 21.15%. KEV: no. Product: GLPI (< 10.0.18). Brief: GLPI: Remote Code Execution via Local File Inclusion (CVE-2025-24801). Brief link: https://feed.craftedsignal.io/briefs/2026-10-glpi-rce/
Triage facts
Revision 1- Applicability
- GLPI (< 10.0.18)
- Evidence
- Unknown
- Severity
- High
- Action
- Elevated
- Sources
- 2 public sources
- Freshness
- Revision 1Oct 29, 14:37 UTC
- Detection
- 1 rule
- Vulnerabilities
- 1 CVE
- Source quality
- B2Very likely
GLPI versions prior to 10.0.18 contain a vulnerability (CVE-2025-24801) allowing Remote Code Execution (RCE) via Local File Inclusion. An authenticated user can interact with the front/documenttype.form.php endpoint and manipulate the ext parameter to permit the upload of unauthorized file types, such as PHP scripts. Successful exploitation results in arbitrary command execution on the host server.
Attack Chain
- Attacker authenticates to the GLPI application with low-level privileges.
- Attacker navigates to the
front/documenttype.form.phpendpoint. - Attacker modifies the allowed file extensions configuration for Document Types via the
extparameter in the request body. - Attacker uploads a malicious PHP file through the application's file upload interface.
- The application saves the file to a location accessible by the web server.
- Attacker triggers execution of the uploaded file by navigating to its path, resulting in RCE.
Impact
Successful exploitation allows an authenticated attacker to execute arbitrary commands with the privileges of the web server, leading to full compromise of the GLPI application instance.
Recommendation
- Upgrade GLPI to version 10.0.18 or later immediately to patch CVE-2025-24801.
- Audit GLPI user accounts to identify and restrict low-privileged users with access to configuration-altering endpoints.
- Monitor web server logs for suspicious POST requests to
front/documenttype.form.phpand subsequent direct access to uploaded files in the web-accessible directories.
Immediate actions
Upgrade GLPI instances to version 10.0.18 or higher.
Threat Hunt
Search web logs for suspicious access to newly uploaded files in directories associated with GLPI document storage.
Data: Web server access logs
Mitigations
Patch GLPI to 10.0.18.
CVE-2025-24801
Detection coverage 1
Detect Potential CVE-2025-24801 Exploitation
highDetects exploitation attempts of CVE-2025-24801 by monitoring POST requests to the documenttype configuration form that contain common PHP-related file extensions in the parameter body.
Detection queries are available on the platform. Get full rules →