Really Simple Security: Authentication Bypass (CVE-2024-10924)
An authentication bypass vulnerability in the Really Simple Security WordPress plugin (versions 9.0.0-9.1.1.1) allows unauthenticated attackers to gain administrative access via the REST API.
CVE search metadata
CVE search record: CVE-2024-10924. Severity: critical. CVSS: 9.8. EPSS: 82.22%. KEV: no. Product: Really Simple Security (< 9.1.2). Brief: Really Simple Security: Authentication Bypass (CVE-2024-10924). Brief link: https://feed.craftedsignal.io/briefs/2026-10-cve-2024-10924-auth-bypass/
Triage facts
Revision 1- Applicability
- Really Simple Security (< 9.1.2)
- Evidence
- Unknown
- Severity
- Critical
- Action
- Immediate escalation
- Sources
- 2 public sources
- Freshness
- Revision 1Oct 28, 15:02 UTC
- Detection
- 1 rule
- Vulnerabilities
- 1 CVE
- Source quality
- B2Very likely
CVE-2024-10924 is a critical authentication bypass vulnerability in the Really Simple Security WordPress plugin, affecting versions 9.0.0 through 9.1.1.1. The flaw exists in the two-factor authentication (2FA) functionality due to improper error handling in the check_login_and_get_user function. An unauthenticated attacker can exploit this by sending a crafted HTTP POST request to the /wp-json/reallysimplessl/v1/two_fa/skip_onboarding REST API endpoint. Successful exploitation allows an attacker to impersonate any user, including accounts with administrative privileges, completely bypassing 2FA requirements. Multiple public exploit scripts are available and confirmed to be circulating.
Attack Chain
- Attacker identifies a WordPress site running the vulnerable Really Simple Security plugin.
- Attacker sends a crafted HTTP POST request to the
/wp-json/reallysimplessl/v1/two_fa/skip_onboardingREST API endpoint. - The vulnerable
check_login_and_get_userfunction fails to validate the request properly due to an error handling flaw. - The application returns valid session cookies for the target user (e.g., admin) to the attacker.
- Attacker retrieves the session cookies from the API response.
- Attacker injects these cookies into their own browser session to access the WordPress dashboard as the targeted user without providing a password or 2FA credentials.
Impact
Successful exploitation results in full administrative access to the affected WordPress installation. This allows for complete site compromise, including arbitrary code execution, data exfiltration, and administrative configuration changes.
Recommendation
- Immediately update the Really Simple Security plugin to version 9.1.2 or later on all WordPress instances.
- Inventory all WordPress installations within the environment to identify any sites running versions 9.0.0 through 9.1.1.1.
- Review web server access logs for anomalous POST requests to the
/wp-json/reallysimplessl/v1/two_fa/skip_onboardingendpoint.
Immediate actions
Update Really Simple Security plugin to 9.1.2 or later
Threat Hunt
Search web logs for POST requests to /wp-json/reallysimplessl/v1/two_fa/skip_onboarding
Data: Web server access logs
Mitigations
Upgrade to Really Simple Security 9.1.2
CVE-2024-10924
Detection coverage 1
Detect CVE-2024-10924 Exploitation Attempt
criticalDetects unauthorized HTTP POST requests to the Really Simple Security skip_onboarding REST endpoint used for authentication bypass.
Detection queries are available on the platform. Get full rules →