Mooveagency Import Xml And Rss Feeds: Arbitrary file upload remote code execution (CVE-2023-4300)
An authenticated remote code execution vulnerability in the Mooveagency Import Xml And Rss Feeds WordPress plugin (CVE-2023-4300) allows high-privilege users to upload and execute arbitrary PHP files.
CVE search metadata
CVE search record: CVE-2023-4300. Severity: high. CVSS: 7.2. EPSS: 2.04%. KEV: no. Product: Import Xml And Rss Feeds (< 2.1.4). Brief: Mooveagency Import Xml And Rss Feeds: Arbitrary file upload remote code execution (CVE-2023-4300). Brief link: https://feed.craftedsignal.io/briefs/2026-10-cve-2023-4300/
Triage facts
Revision 1- Applicability
- Import Xml And Rss Feeds (< 2.1.4)
- Evidence
- Unknown
- Severity
- High
- Action
- Elevated
- Sources
- 2 public sources
- Freshness
- Revision 1Oct 31, 06:06 UTC
- Detection
- 1 rule
- Vulnerabilities
- 1 CVE
- Source quality
- C3Likely
CVE-2023-4300 is an arbitrary file upload vulnerability in the Import Xml And Rss Feeds WordPress plugin versions prior to 2.1.4. The vulnerability exists within the 'moove_save_import_template' action, accessible via 'admin-ajax.php'. Successful exploitation requires high-level administrative privileges and allows an attacker to upload arbitrary PHP files due to insufficient file extension validation, leading to remote code execution.
Impact
Successful exploitation results in full remote code execution on the underlying web server, allowing for complete system compromise within the context of the web application user.
Recommendation
Update the Import Xml And Rss Feeds plugin to version 2.1.4 or later immediately. Ensure that administrative access to WordPress is strictly controlled to mitigate the impact of this authenticated-only vulnerability.
Immediate actions
Inventory WordPress sites for Import Xml And Rss Feeds plugin version < 2.1.4
Mitigations
Upgrade Import Xml And Rss Feeds to version 2.1.4 or higher
CVE-2023-4300
Detection coverage 1
Detect CVE-2023-4300 Exploitation - Arbitrary PHP File Upload via admin-ajax.php
highDetects exploitation of CVE-2023-4300 where an authenticated user makes a POST request to admin-ajax.php triggering the moove_save_import_template action with an uploaded file.
Detection queries are available on the platform. Get full rules →